Date Category ニュース.
Pocket

bashに見つかった脆弱性「ShellShock」のOpenVPNへの影響については、threatpostの「OpenVPN Vulnerable to Shellshock Bash Vulnerability」などで取り上げられていますが、以下の条件に合致する場合に影響します。

  • ID/パスワード認証などで、OpenVPNから外部コマンドを呼び出している(auth-user-pass-verifyディレクティブを使用している)
  • 呼び出される外部コマンドでbashを使用し、環境変数で値を渡している

詳細についてはこちらもご参照ください。